LockDown Browser error

Issue

Student is unable to take an exam using LockDown Browser (LDB). When opening the exam through LDB they receive the following error, "This program can only be launched by a link in another browser," and/or are prompted to repeatedly download LDB (See Fig. 1).
Figure 1:  LockDown Browser error
Figure 1:  LockDown Browser error

Cause

Student has an old version of LDB. Note: This can happen if a student searches for and downloads LDB rather than using the UM System-licensed version.

Solution

Student should uninstall the old version, reboot their computer, then return to the exam in Canvas and follow the prompts to download and install the current version of LDB.

 

LockDown Browser campus and vendor resources

Print Article

Related Services / Offerings (1)

LockDown Browser helps prevent cheating on online quizzes via a special browser window.